summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2022-04-05 22:35:16 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-08 00:09:04 +0200
commit7fbf02b854ce694b890f00b3879258e8b2a7ac4b (patch)
tree02cc1b52bb03f79471ee2775cceceab8556af821
parent1ba8c74de362f2f79bdec834c14e46105f6e801b (diff)
downloadguix-patches-7fbf02b854ce694b890f00b3879258e8b2a7ac4b.tar
guix-patches-7fbf02b854ce694b890f00b3879258e8b2a7ac4b.tar.gz
gnu: Add emacs-toodoo.
* gnu/packages/emacs-xyz.scm (emacs-toodoo): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 630d3aa430..c00872109a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -94,7 +94,7 @@
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
-;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021, 2022 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
@@ -13038,6 +13038,30 @@ properties are set on a heading, and when it is changing from a TODO state to
a DONE state.")
(license license:gpl3+)))
+(define-public emacs-toodoo
+ ;; Package has no release. Version is extracted from "Version:" keyword in
+ ;; main file, and commit below matches version bump.
+ (package
+ (name "emacs-toodoo")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ChanderG/toodoo.el")
+ (commit "149a563863c2f728c5f903475dbce50547c51000")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00q7aym0kl03j9m66pivgy0snxcjjg402049b2wdy18kgyypfvx8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-transient emacs-evil))
+ (home-page "https://github.com/ChanderG/toodoo.el")
+ (synopsis "Magit-like interface for a Todo workflow built on top of Org")
+ (description "This package provides a minor mode for fast and easy management of Todos
+using Org mode and transients.")
+ (license license:asl2.0)))
+
(define-public emacs-flx
(package
(name "emacs-flx")