summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
commit525f1013d1825081e90afce8512550b26d032dcc (patch)
tree6c9624b2932eb0e4f1ee909b13374a96e7d417eb
parent0c5299200ffcd16370f047b7ccb187c60f30da34 (diff)
downloadguix-patches-525f1013d1825081e90afce8512550b26d032dcc.tar
guix-patches-525f1013d1825081e90afce8512550b26d032dcc.tar.gz
gnu: cairomm: Update to 1.16.1.
* gnu/packages/gtk.scm (cairomm): Update to 1.16.1. [arguments]: Don't explicitly return #t from phases.
-rw-r--r--gnu/packages/gtk.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3bf986403a..a71501d8a3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2016 Patrick Hetu <patrick.hetu@auf.org>
;;; Copyright © 2016 Nikita <nikita@n0.is>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018, 2020 Arun Isaac <arunisaac@systemreboot.net>
@@ -1563,14 +1563,14 @@ guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
(define-public cairomm
(package
(name "cairomm")
- (version "1.16.0")
+ (version "1.16.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cairographics.org/releases/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1ya4y7qa000cjawqwswbqv26y5icfkmhs5iiiil4dxgrqn91923y"))))
+ "1im2yjzvjfx8s7cal9kwq23z936kppfmyag2zsnbim4dx7c60q3g"))))
(build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
@@ -1588,8 +1588,7 @@ guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
(mkdir-p (string-append doc "/share"))
(rename-file
(string-append out "/share/doc")
- (string-append doc "/share/doc"))
- #t))))))
+ (string-append doc "/share/doc"))))))))
(native-inputs
`(("boost" ,boost)
("dot" ,graphviz)