summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-07 19:11:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-07 19:11:48 +0300
commit413b85ad4f033354038ba3a65948de029a5e638d (patch)
tree778a29648dc83f9b2ddc3b73c777436ed78eaf0f
parent96d47797dce361bd7f3b1ce860b1ec4851e2db5a (diff)
downloadguix-patches-413b85ad4f033354038ba3a65948de029a5e638d.tar
guix-patches-413b85ad4f033354038ba3a65948de029a5e638d.tar.gz
gnu: Remove unused patch.
* gnu/packages/patches/python-flake8-polyfill-flake8-4-compat.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-flake8-polyfill-flake8-4-compat.patch32
2 files changed, 0 insertions, 33 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4e58df6ff7..68b317b32a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1593,7 +1593,6 @@ dist_patch_DATA = \
%D%/packages/patches/ppsspp-disable-upgrade-and-gold.patch \
%D%/packages/patches/pthreadpool-system-libraries.patch \
%D%/packages/patches/python-chai-drop-python2.patch \
- %D%/packages/patches/python-flake8-polyfill-flake8-4-compat.patch \
%D%/packages/patches/python-random2-getrandbits-test.patch \
%D%/packages/patches/python-poppler-qt5-fix-build.patch \
%D%/packages/patches/python-w3lib-fix-test-failure.patch \
diff --git a/gnu/packages/patches/python-flake8-polyfill-flake8-4-compat.patch b/gnu/packages/patches/python-flake8-polyfill-flake8-4-compat.patch
deleted file mode 100644
index 7f5babd07d..0000000000
--- a/gnu/packages/patches/python-flake8-polyfill-flake8-4-compat.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://github.com/PyCQA/flake8-polyfill/commit/3cf414350e82ceb835ca2edbd5d5967d33e9ff35.patch
-
-
-From 3cf414350e82ceb835ca2edbd5d5967d33e9ff35 Mon Sep 17 00:00:00 2001
-From: Ian Stapleton Cordasco <graffatcolmingov@gmail.com>
-Date: Mon, 1 Nov 2021 19:18:04 -0500
-Subject: [PATCH] Skip unnecessary tests on Flake8 4.x+
-
----
- tests/test_stdin.py | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/tests/test_stdin.py b/tests/test_stdin.py
-index 4350967..212b309 100644
---- a/tests/test_stdin.py
-+++ b/tests/test_stdin.py
-@@ -1,4 +1,5 @@
- """Tests for polyfill's stdin monkey patching."""
-+import flake8
- import pep8
- import pycodestyle
- import pytest
-@@ -6,6 +7,9 @@
- from flake8_polyfill import stdin
- from flake8_polyfill import version
-
-+if (4, 0, 0) <= flake8.__version_info__:
-+ pytestmark = pytest.mark.skip
-+
-
- def test_modules_dict():
- """Verify that it works the way we expect."""