summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Albers <thomas@thomaslabs.org>2022-06-08 00:02:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-08 00:02:53 +0200
commit1ba8c74de362f2f79bdec834c14e46105f6e801b (patch)
tree0aeaacd25967904d6fe6e9a85860dd7e85357e32
parent9105c60f0d125852678327a1ded1d2f588eb46f0 (diff)
downloadguix-patches-1ba8c74de362f2f79bdec834c14e46105f6e801b.tar
guix-patches-1ba8c74de362f2f79bdec834c14e46105f6e801b.tar.gz
gnu: Add emacs-opencl-mode.
* gnu/packages/emacs-xyz.scm (emacs-opencl-mode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bb5af77422..630d3aa430 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -112,6 +112,7 @@
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -15804,6 +15805,30 @@ of commands is displayed in a handy popup.")
characters from end of lines.")
(license license:gpl3+)))
+(define-public emacs-opencl-mode
+ ;; Upstream never makes any formal releases, there is only v1.0.
+ ;; Use the latest commit instead.
+ (let ((commit "15091eff92c33ee0d1ece40eb99299ef79fee92d")
+ (revision "1"))
+ (package
+ (name "emacs-opencl-mode")
+ (version (git-version "1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/salmanebah/opencl-mode")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zn6rr48w0ai0sn51zzyp546va6flfgf9lm12vfrdb6kkiiiq403"))))
+ (build-system emacs-build-system)
+ (synopsis "Emacs major mode for editing OpenCL kernels")
+ (description "This Emacs package provides the @code{opencl-mode} major
+mode for editing OpenCL kernels. It supports syntax highlighting and online
+access to the OpenCL documentation through the @code{opencl-lookup} function.")
+ (home-page "https://github.com/salmanebah/opencl-mode")
+ (license license:gpl3+))))
+
(define-public emacs-openwith
;; There is no release tag. Version is extracted from main file.
(let ((version "20120531")