summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Polidoro <peter@polidoro.io>2022-05-27 14:57:26 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-06 22:43:30 +0200
commitf08bfca0836ea515ea8ddcfb72d319fd6838908a (patch)
tree57cee8e4d336777ff6ca5e431731b8c9196c064f
parent2aceb1e13ee994385bd20cfc8a59346366447199 (diff)
downloadguix-patches-f08bfca0836ea515ea8ddcfb72d319fd6838908a.tar
guix-patches-f08bfca0836ea515ea8ddcfb72d319fd6838908a.tar.gz
gnu: Add python-progress.
* gnu/packages/python-xyz.scm (python-progress): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 17e9a922fb..9a84f9e534 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13883,6 +13883,25 @@ to the Python ecosystem.")
"Promises/A+ implementation for Python")
(license license:expat)))
+(define-public python-progress
+ (package
+ (name "python-progress")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "progress" version))
+ (sha256
+ (base32 "1k9lpb7lqr6mywpnqcz71y6qny54xlgprdp327za2gy0nnc6xj69"))))
+ (build-system python-build-system)
+ (home-page "http://github.com/verigak/progress/")
+ (synopsis "Progress reporting bars for Python")
+ (description "This Python package provides progress reporting for visual
+of progress of long running operations. There are multiple choices of
+progress bars and spinners, with customizable options, such as width, fill
+character, and suffix.")
+ (license license:isc)))
+
(define-public python-progressbar2
(package
(name "python-progressbar2")