summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-02-14 23:07:42 +0100
committerLudovic Courtès <ludo@gnu.org>2019-02-16 01:00:08 +0100
commit8a973abc6f7eebfcd8a904bfbb99cb9f86f66ef0 (patch)
tree3b7492e9a563d3fa6289ba0d3af5005ae3f7fe75
parente6e599fa0106f57b9de15f90dcab3795ff1575b6 (diff)
downloadguix-patches-8a973abc6f7eebfcd8a904bfbb99cb9f86f66ef0.tar
guix-patches-8a973abc6f7eebfcd8a904bfbb99cb9f86f66ef0.tar.gz
gnu: guix: Embed 'glibc-utf8-locales'.
This will ensure people who download the binary installation tarball do not get locale-related warnings, provided they use one of the selected UTF-8 locales. * gnu/packages/package-management.scm (guix)[arguments]: In 'wrap-program' phase, set GUIX_LOCPATH. [inputs]: Add GLIBC-UTF8-LOCALES.
-rw-r--r--gnu/packages/package-management.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index eff8d5c3fd..44c6c1c21d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages avahi)
#:use-module (gnu packages autotools)
#:use-module (gnu packages backup)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bdw-gc)
#:use-module (gnu packages bison)
#:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
@@ -228,6 +229,7 @@
"guile-bytestructures"))
(ssh (assoc-ref inputs "guile-ssh"))
(gnutls (assoc-ref inputs "gnutls"))
+ (locales (assoc-ref inputs "glibc-utf8-locales"))
(deps (list gcrypt json sqlite gnutls
git bs ssh))
(effective
@@ -246,11 +248,13 @@
"/lib/guile/" effective
"/site-ccache")
(delete #f deps))
- ":")))
+ ":"))
+ (locpath (string-append locales "/lib/locale")))
(wrap-program (string-append out "/bin/guix")
`("GUILE_LOAD_PATH" ":" prefix (,path))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,gopath)))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,gopath))
+ `("GUIX_LOCPATH" ":" suffix (,locpath)))
#t))))))
(native-inputs `(("pkg-config" ,pkg-config)
@@ -283,7 +287,9 @@
,@(if (and (not (%current-target-system))
(string=? (%current-system) "x86_64-linux"))
`(("boot-guile/i686" ,(bootstrap-guile-origin "i686-linux")))
- '())))
+ '())
+
+ ("glibc-utf8-locales" ,glibc-utf8-locales)))
(propagated-inputs
`(("gnutls" ,gnutls)
("guile-gcrypt" ,guile-gcrypt)