summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-06 14:12:04 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-07 09:11:51 -0400
commit5022cf8e044cadaad41660f97c0a763ff0a81688 (patch)
tree31f1e4a674a3fb0c4b0c35837223186f8a1fd968
parentf4696aeb943c5ece7082b686786fcc0c26c7b88c (diff)
downloadguix-patches-5022cf8e044cadaad41660f97c0a763ff0a81688.tar
guix-patches-5022cf8e044cadaad41660f97c0a763ff0a81688.tar.gz
gnu: python-flake8: Update to 4.0.1.
* gnu/packages/python-xyz.scm (python-flake8): Update to 4.0.1. [phases]{check}: Delete extraneous add-installed-pythonpath call. [propagated-inputs]: Re-indent. [native-inputs]: Remove python-mock.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ce64f129f..eefb08ae6a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10229,13 +10229,15 @@ cyclomatic complexity of Python source code.")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "pytest" "-v")))))))
- (propagated-inputs (list python-pycodestyle python-entrypoints
- python-pyflakes python-mccabe))
- (native-inputs (list python-mock python-pytest))
+ (propagated-inputs
+ (list python-entrypoints
+ python-mccabe
+ python-pycodestyle
+ python-pyflakes))
+ (native-inputs (list python-pytest))
(home-page "https://gitlab.com/pycqa/flake8")
(synopsis "The modular source code checker: pep8, pyflakes and co")
(description