summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-07 09:24:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-07 09:24:14 +0300
commit0fd5222ad61fb1d2a776d018e1dd7161e50bea41 (patch)
treeb3708c07a841f5544ae59065ac7c7c2273c91171
parent49a47bdcc5fb6dd8363917ea005fb51155c8e266 (diff)
downloadguix-patches-0fd5222ad61fb1d2a776d018e1dd7161e50bea41.tar
guix-patches-0fd5222ad61fb1d2a776d018e1dd7161e50bea41.tar.gz
gnu: python-flake8-polyfill: Honor tests? flag.
* gnu/packages/python-xyz.scm (python-flake8-polyfill)[arguments]: Adjust custom 'check phase to honor the #:tests? flag.
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d5ad05f4d9..f4ae6a7e62 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10366,13 +10366,14 @@ unnecessary plus operators for explicit string literal concatenation.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
+ (lambda* (#:key tests? #:allow-other-keys)
;; Be compatible with Pytest 4:
;; https://gitlab.com/pycqa/flake8-polyfill/merge_requests/7
(substitute* "setup.cfg"
(("\\[pytest\\]")
"[tool:pytest]"))
- (invoke "py.test" "-v"))))))
+ (when tests?
+ (invoke "py.test" "-v")))))))
(propagated-inputs
(list python-flake8))
(native-inputs