summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-05 02:00:00 +0200
commit7f2328b7df06414630aaa2aef08da226d6082f87 (patch)
treed276e78266f77af77befc831a5eaef242cefe6d0
parentaeca46ae0fba3e06b81af458bca27315de0e7c7d (diff)
downloadguix-patches-7f2328b7df06414630aaa2aef08da226d6082f87.tar
guix-patches-7f2328b7df06414630aaa2aef08da226d6082f87.tar.gz
gnu: guvcview: Update to 2.0.8.
* gnu/packages/video.scm (guvcview): Update to 2.0.8. [inputs]: Add bdb and libjpeg-turbo.
-rw-r--r--gnu/packages/video.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d10382a738..266379ad44 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -120,6 +120,7 @@
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages dbm)
#:use-module (gnu packages dejagnu)
#:use-module (gnu packages dns)
#:use-module (gnu packages docbook)
@@ -5336,14 +5337,14 @@ wlroots-based compositors. More specifically, those that support
(define-public guvcview
(package
(name "guvcview")
- (version "2.0.6")
+ (version "2.0.8")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/guvcview/source/guvcview-"
- "src-" version ".tar.gz"))
+ "src-" version ".tar.bz2"))
(sha256
(base32
- "11byyfpkcik7wvf2qic77zjamfr2rhji97dpj1gy2fg1bvpiqf4m"))))
+ "108c4g0ns9i1wnxyalmpjqbhlflmrj855vxgggr6qrl6h924w7x2"))))
(build-system gnu-build-system)
(arguments
;; There are no tests and "make check" would fail on an intltool error.
@@ -5351,11 +5352,13 @@ wlroots-based compositors. More specifically, those that support
(native-inputs
(list pkg-config intltool))
(inputs
- (list gtk+
+ (list bdb
+ gtk+
eudev
+ libjpeg-turbo
libusb
- v4l-utils ;libv4l2
- ffmpeg ;libavcodec, libavutil
+ v4l-utils ;libv4l2
+ ffmpeg ;libavcodec, libavutil
sdl2
gsl
portaudio