summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-13 23:48:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-13 23:50:02 +0200
commitea7882b2e397633eccf2ec7205404bec30f74312 (patch)
treeaf1948e7abca53c80263072d8c6e96ddf1e82e9d
parent401e6ccb121726850242cd4d8d710049bc82fc92 (diff)
downloadguix-patches-ea7882b2e397633eccf2ec7205404bec30f74312.tar
guix-patches-ea7882b2e397633eccf2ec7205404bec30f74312.tar.gz
gnu: alsa-modular-synth: Hide default GCC.
* gnu/packages/audio.scm (alsa-modular-synth)[native-inputs]: Distinguish GCC-5. [arguments]: Add build phase "hide-default-gcc".
-rw-r--r--gnu/packages/audio.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 7f9720d257..b2ffeffd40 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -185,6 +185,17 @@ implementation of Adaptive Multi Rate Narrowband and Wideband
"CXXFLAGS=-std=gnu++11")
#:phases
(modify-phases %standard-phases
+ (add-after 'set-paths 'hide-default-gcc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref inputs "gcc")))
+ ;; Remove the default GCC from CPLUS_INCLUDE_PATH to prevent
+ ;; conflicts with the GCC 5 input.
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-join
+ (delete (string-append gcc "/include/c++")
+ (string-split (getenv "CPLUS_INCLUDE_PATH") #\:))
+ ":"))
+ #t)))
;; Insert an extra space between linker flags.
(add-before 'configure 'add-missing-space
(lambda _
@@ -205,7 +216,7 @@ implementation of Adaptive Multi Rate Narrowband and Wideband
(native-inputs
`(("pkg-config" ,pkg-config)
("qttools" ,qttools)
- ("gcc" ,gcc-5)))
+ ("gcc@5" ,gcc-5)))
(home-page "http://alsamodular.sourceforge.net/")
(synopsis "Realtime modular synthesizer and effect processor")
(description