summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-31 10:35:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-03-31 10:36:31 +0200
commitea403bf290f4bf8c7bae314e32dbb90653f92996 (patch)
treef5af05adf2177f477dc813347a4b33be361e2ee6
parent967d5fd5c24883e0e33ca9b2f5b7d8a12805d57f (diff)
downloadguix-patches-ea403bf290f4bf8c7bae314e32dbb90653f92996.tar
guix-patches-ea403bf290f4bf8c7bae314e32dbb90653f92996.tar.gz
gnu: python-h5py: Update to 3.6.0.
* gnu/packages/python-xyz.scm (python-h5py): Update to 3.6.0. [arguments]: Set HDF5_DIR variable instead of patching files.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a4d86ace92..9e05908303 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1349,14 +1349,14 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
(define-public python-h5py
(package
(name "python-h5py")
- (version "2.10.0")
+ (version "3.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "h5py" version))
(sha256
(base32
- "0baipzv8n93m0dq0riyi8rfhzrjrfrfh8zqhszzp1j2xjac2fhc4"))))
+ "0afv805vqrm5071g7alwv41920nhh8kjv4m5nbia9awj9a0x4ll7"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no test target
@@ -1364,16 +1364,7 @@ NetCDF files can also be read and modified. Python-HDF4 is a fork of
(modify-phases %standard-phases
(add-after 'unpack 'fix-hdf5-paths
(lambda* (#:key inputs #:allow-other-keys)
- (let ((prefix (assoc-ref inputs "hdf5")))
- (substitute* "setup_build.py"
- (("\\['/opt/local/lib', '/usr/local/lib'\\]")
- (string-append "['" prefix "/lib" "']"))
- (("'/opt/local/include', '/usr/local/include'")
- (string-append "'" prefix "/include" "'")))
- (substitute* "setup_configure.py"
- (("\\['/usr/local/lib', '/opt/local/lib'\\]")
- (string-append "['" prefix "/lib" "']")))
- #t))))))
+ (setenv "HDF5_DIR" (assoc-ref inputs "hdf5")))))))
(propagated-inputs
(list python-six python-numpy))
(inputs