summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2022-06-05 17:38:38 +0200
committerJelle Licht <jlicht@fsfe.org>2022-06-06 15:38:23 +0200
commite71f35df74f970a93e0b178fc5a294781b88883a (patch)
tree465d723a57ad66c53ee0671c841ae9fe93777357
parent6b96ef08b927f630f7a98b11b466bd445b58d10d (diff)
downloadguix-patches-e71f35df74f970a93e0b178fc5a294781b88883a.tar
guix-patches-e71f35df74f970a93e0b178fc5a294781b88883a.tar.gz
gnu: node: Fix cross-compilation.
* gnu/packages/node.scm (node)[phases]{configure}: Unwind the stack before invoking the exception handler. {patch-hardcoded-program-references}: Use search-input-file where appropriate.
-rw-r--r--gnu/packages/node.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 41c01cf7e4..c8d81fbd22 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -128,7 +128,7 @@
(cons sigxfsz common)
common))
(("'/bin/sh'")
- (string-append "'" (assoc-ref inputs "bash") "/bin/sh'")))
+ (string-append "'" (search-input-file inputs "/bin/sh") "'")))
;; Fix hardcoded /usr/bin/env references.
(substitute* '("test/parallel/test-child-process-default-options.js"
@@ -245,7 +245,8 @@
(search-input-file inpts "/bin/python3")
(raise-exception e)))
(lambda ()
- (search-input-file inpts "/bin/python"))))
+ (search-input-file inpts "/bin/python"))
+ #:unwind? #t))
"configure"
flags))))
(add-after 'patch-shebangs 'patch-nested-shebangs