summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-06 15:30:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-06 15:31:18 +0200
commite6df9f92f54d6c2be70d014a3a1506d0c4887968 (patch)
tree5f4b3e8b363cc04034a2653492112c0c500ed48c
parent143141726e6c1b3f1170e9f4e971700e30d74375 (diff)
downloadguix-patches-e6df9f92f54d6c2be70d014a3a1506d0c4887968.tar
guix-patches-e6df9f92f54d6c2be70d014a3a1506d0c4887968.tar.gz
gnu: python-rope: Update to 1.1.1.
* gnu/packages/python-xyz.scm (python-rope): Update to 1.1.1. [arguments]: Add build phase to disable broken test. [native-inputs]: Add python-pytest and python-pytest-timeout. [description]: Remove explicit mention of Python 2.
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0dfc6ca7e0..1bed505a56 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15484,20 +15484,33 @@ respectively.")
(define-public python-rope
(package
(name "python-rope")
- (version "0.19.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rope" version))
(sha256
(base32
- "1nlhkmsfvn2p1msrmwqnypnvr993alzawnpc1605q7rfad3xgrk4"))))
+ "0bkzwkllxxdxd3w70xiy137lqvnlmmaplsc2ya3s23ss4kq8y10k"))))
(build-system python-build-system)
+ (arguments
+ (list #:phases
+ `(modify-phases %standard-phases
+ (add-after 'unpack 'disable-broken-test
+ (lambda _
+ (substitute* "ropetest/contrib/autoimporttest.py"
+ (("def test_search_module")
+ "def __notest_search_module")
+ (("def test_search_submodule")
+ "def __notest_search_submodule")))))))
+ (native-inputs
+ (list python-pytest-timeout
+ python-pytest))
(home-page "https://github.com/python-rope/rope")
(synopsis "Refactoring library for Python")
(description "Rope is a refactoring library for Python. It facilitates
the renaming, moving and extracting of attributes, functions, modules, fields
-and parameters in Python 2 source code. These refactorings can also be applied
+and parameters in Python source code. These refactorings can also be applied
to occurrences in strings and comments.")
(license license:lgpl3+)))