summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-11-30 10:49:01 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-30 22:05:58 +0100
commite318c3a6aa7b0bc07d84ccbdf8d1ca90a39d34d3 (patch)
tree79e505a8952f455300ca19cd38a629fad536d4b3
parentaaa1b8049918a3eea32fb0f5d04fb96c59dbcf2b (diff)
downloadguix-patches-e318c3a6aa7b0bc07d84ccbdf8d1ca90a39d34d3.tar
guix-patches-e318c3a6aa7b0bc07d84ccbdf8d1ca90a39d34d3.tar.gz
gnu: python-tomlkit: Update to 0.7.0.
* gnu/packages/python-xyz.scm (python-tomlkit): Update to 0.7.0. [native-inputs]: Add python-pyyaml. [description]: Update description. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d34867dc56..affeeb080e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13021,20 +13021,21 @@ docstring and colored output.")
(define-public python-tomlkit
(package
(name "python-tomlkit")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tomlkit" version))
(sha256
- (base32 "16jf0060csn8p500jnxa7m5h1sl3pzispvd11961dzrhh287dybl"))))
+ (base32 "062n694sfv24ylda6nh8228y2q9hrvy554kqx84y7czsjfbg4mxc"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)
+ ("python-pyyaml" ,python-pyyaml)))
(home-page "https://github.com/sdispater/tomlkit")
(synopsis "Style-preserving TOML library")
(description
- "TOML Kit is a 0.5.0-compliant TOML library. It includes a parser that
+ "TOML Kit is a 1.0.0rc1-compliant TOML library. It includes a parser that
preserves all comments, indentations, whitespace and internal element ordering,
and makes them accessible and editable via an intuitive API. It can also
create new TOML documents from scratch using the provided helpers. Part of the