summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-21 20:24:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:21 -0500
commitdf20439d442759473579323d62fd2eb566d849e6 (patch)
tree37aa344ab6c36be8b99cc722745efd7c2aaa5b63
parent8f78f61c029bb45c39fa782f8ac2c6962e44cdab (diff)
downloadguix-patches-df20439d442759473579323d62fd2eb566d849e6.tar
guix-patches-df20439d442759473579323d62fd2eb566d849e6.tar.gz
gnu: jsoncpp: Apply patch to regular package.
* gnu/packages/serialization.scm (jsoncpp)[source]: Apply patch. (jsoncpp-with-pkg-version): Delete variant package. * gnu/packages/jami.scm (libring)[inputs]: Adjust accordingly.
-rw-r--r--gnu/packages/jami.scm2
-rw-r--r--gnu/packages/serialization.scm21
2 files changed, 3 insertions, 20 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 7d71837fd1..5cb92840dc 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -422,7 +422,7 @@
("eudev" ,eudev)
("ffmpeg" ,ffmpeg-jami)
("jack" ,jack-1)
- ("jsoncpp" ,jsoncpp-with-pkg-version)
+ ("jsoncpp" ,jsoncpp)
("libarchive" ,libarchive)
("libgit2" ,libgit2)
("libnatpmp" ,libnatpmp)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index dc21dba10b..4501dfb62d 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -425,6 +425,8 @@ in which the loaded data is arranged in memory.")
(method git-fetch)
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
+ (patches
+ (search-patches "jsoncpp-pkg-config-version.patch"))
(sha256
(base32
"0qnx5y6c90fphl9mj9d20j2dfgy6s5yr5l0xnzid0vh71zrp6jwv"))))
@@ -444,25 +446,6 @@ preserve existing comment in unserialization/serialization steps, making
it a convenient format to store user input files.")
(license license:expat)))
-;; XXX: TODO(core-updates): Remove this package and apply the patch to the
-;; jsoncpp package. This patch fixes the package version declared in the
-;; pkg-config file.
-(define-public jsoncpp-with-pkg-version
- (package
- (inherit jsoncpp)
- (name "jsoncpp")
- (version "1.9.4")
- (home-page "https://github.com/open-source-parsers/jsoncpp")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page) (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0qnx5y6c90fphl9mj9d20j2dfgy6s5yr5l0xnzid0vh71zrp6jwv"))
- (patches
- (search-patches "jsoncpp-pkg-config-version.patch"))))))
-
;; Tensorflow does not build with jsoncpp 1.8.x. It is built with commit
;; 4356d9bba191e1e16ce7a92073cbf3e63564e973, which lies between version 1.7.2
;; and 1.7.3.