summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-05-30 22:57:49 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-06-05 21:27:52 +0200
commitddb7e35bc4eb177d3cfe78973265851b8ab67361 (patch)
tree41e9642b85becb9282d775a6dd128fd3c657e3d9
parent21ca4719b3996b7c752f5e996e801d67c3bf2748 (diff)
downloadguix-patches-ddb7e35bc4eb177d3cfe78973265851b8ab67361.tar
guix-patches-ddb7e35bc4eb177d3cfe78973265851b8ab67361.tar.gz
gnu: Add python-musical-scales
* gnu/packages/python-xyz.scm (python-musical-scales): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 979a11a5a6..bcc65e289f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29293,3 +29293,24 @@ profile. It supports:
Currently, Linux is the only platform supported by this library.")
(license license:expat)))
+
+(define-public python-musical-scales
+ (package
+ (name "python-musical-scales")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "musical-scales" version))
+ (sha256
+ (base32
+ "1ckn8n37i7b65h0i385ycn0w8sg9na0iabz0kmhxxc1wj0hddkw9"))))
+ (build-system python-build-system)
+ (native-inputs (list python-wheel))
+ (home-page "https://github.com/hmillerbakewell/musical-scale")
+ (synopsis "Retrieve a scale based on a given mode and starting note")
+ (description
+ "Retrieve a scale based on a given mode and starting note.
+Information about these scales can be
+@url{https://en.wikipedia.org/wiki/List_of_musical_scales_and_modes, found on
+Wikipedia}.")
+ (license license:expat)))