summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-22 10:50:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-22 10:50:58 +0300
commitcc4906d13b3749c4caff6ec8034bdaf2c7ff7da2 (patch)
treeae6428976f38991f6121aaa934b68d27d031ddbe
parent309b38bed61c21ce8ba559a679592ecc1c94dbfc (diff)
downloadguix-patches-cc4906d13b3749c4caff6ec8034bdaf2c7ff7da2.tar
guix-patches-cc4906d13b3749c4caff6ec8034bdaf2c7ff7da2.tar.gz
gnu: Add htslib-1.10.
* gnu/packages/bioinformatics.scm (htslib-1.10): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9bbb164331..0b19b02f46 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4652,6 +4652,19 @@ data. It also provides the @command{bgzip}, @command{htsfile}, and
;; the rest is released under the Expat license
(license (list license:expat license:bsd-3))))
+(define-public htslib-1.10
+ (package (inherit htslib)
+ (name "htslib")
+ (version "1.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/samtools/htslib/releases/download/"
+ version "/htslib-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0wm9ay7qgypj3mwx9zl1mrpnr36298b1aj5vx69l4k7bzbclvr3s"))))))
+
(define-public htslib-1.9
(package (inherit htslib)
(name "htslib")