summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 10:16:42 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 12:08:48 +0300
commitb507646160b1c20ce9bbb5a74a5f5bc842fa21b1 (patch)
treea35d606c8c547c57a9653131495b005d8d434ac0
parent538884ccef762c3410bf2a75af236803eca6b024 (diff)
downloadguix-patches-b507646160b1c20ce9bbb5a74a5f5bc842fa21b1.tar
guix-patches-b507646160b1c20ce9bbb5a74a5f5bc842fa21b1.tar.gz
gnu: tinyproxy: Update to 1.8.4 [Fixes CVE-2012-3505].
* gnu/packages/web.scm (tinyproxy): Update to 1.8.4. [source]: Download from new location. [home-page]: Project has moved to Github.
-rw-r--r--gnu/packages/web.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9a7f9d2b3c..f1e03da3ca 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -528,16 +528,15 @@ used to validate and fix HTML data.")
(define-public tinyproxy
(package
(name "tinyproxy")
- (version "1.8.3")
+ (version "1.8.4")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://download.banu.com/tinyproxy/"
- (version-major+minor version)
- "/tinyproxy-" version ".tar.gz"))
+ (uri (string-append "https://github.com/tinyproxy/tinyproxy/"
+ "releases/download/" version "/tinyproxy-"
+ version ".tar.xz"))
(sha256
(base32
- "05y0y2q9j10x72y1fipya6bmc8hjcdf3kfw7dh8ahczpy341c938"))))
+ "002hi97687czhfkwsjkr174yvlp10224qi6gd5s53z230bgls7x4"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -560,7 +559,7 @@ used to validate and fix HTML data.")
("docbook-xml" ,docbook-xml)
("docbook-xsl" ,docbook-xsl)
("libxslt" ,libxslt)))
- (home-page "https://banu.com/tinyproxy/")
+ (home-page "https://tinyproxy.github.io/")
(synopsis "Light-weight HTTP/HTTPS proxy daemon")
(description "Tinyproxy is a light-weight HTTP/HTTPS proxy
daemon. Designed from the ground up to be fast and yet small, it is an ideal