summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-04-16 00:35:27 -0400
committerEfraim Flashner <efraim@flashner.co.il>2021-07-22 11:48:41 +0300
commita9094600992276a0786784b4c604705fcbe7e852 (patch)
treef11de4c4fd08635bee583e230a996da377c75aec
parent454460ca55c77aacae90b68150f305c8db10af8a (diff)
downloadguix-patches-a9094600992276a0786784b4c604705fcbe7e852.tar
guix-patches-a9094600992276a0786784b4c604705fcbe7e852.tar.gz
gnu: Add abjad-ext-rmakers.
* gnu/packages/music.scm (abjad-ext-rmakers): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/music.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index dbb2005aca..19cad30774 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1617,6 +1617,48 @@ typographic detail of symbols on the page.")
(define-public python-abjad
(deprecated-package "python-abjad" abjad))
+(define-public abjad-ext-rmakers
+ (package
+ (name "abjad-ext-rmakers")
+ (version "3.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Abjad/abjad-ext-rmakers")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03nry8lzh3s81yq4lw8y6j63m7zdsl20q7rvx9cfmp3rmbvlaycs"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest" ".")
+ #t))))))
+ (native-inputs
+ `(("lilypond" ,lilypond)
+ ("python-black" ,python-black)
+ ("python-flake8" ,python-flake8)
+ ("python-iniconfig" ,python-iniconfig)
+ ("python-isort" ,python-isort)
+ ("python-mypy" ,python-mypy)
+ ("python-pytest" ,python-pytest-6)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-helpers-namespace" ,python-pytest-helpers-namespace)))
+ (propagated-inputs
+ `(("abjad" ,abjad)))
+ (home-page "https://abjad.github.io")
+ (synopsis "Abjad rhythm-maker exension package")
+ (description
+ "@code{abjad-ext-rmakers} includes a collection of classes for creating and
+and manipulating rhythms such as accelerandi, taleas, and more.")
+ (license license:expat)))
+
(define-public non-sequencer
;; The latest tagged release is three years old and uses a custom build
;; system, so we take the last commit.