summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-08-29 22:54:24 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-06 09:08:48 -0400
commit96e76083b82659429cd46e9abe2323678fd98e87 (patch)
tree155aa79175568e130873f7c37cb2fcba44097d70
parent5337f8b97ddc754d04c2888822295602554d3944 (diff)
downloadguix-patches-96e76083b82659429cd46e9abe2323678fd98e87.tar
guix-patches-96e76083b82659429cd46e9abe2323678fd98e87.tar.gz
gnu: Add ruby-pry.
* gnu/packages/ruby.scm (ruby-pry): New variable.
-rw-r--r--gnu/packages/ruby.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index b85bf82b80..d3babbe5d2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -896,3 +896,28 @@ extract comments.")
for select languages.")
(home-page "http://coderay.rubychan.de")
(license license:expat)))
+
+(define-public ruby-pry
+ (package
+ (name "ruby-pry")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pry" version))
+ (sha256
+ (base32
+ "1j0r5fm0wvdwzbh6d6apnp7c0n150hpm9zxpm5xvcgfqr36jaj8z"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (propagated-inputs
+ `(("ruby-coderay" ,ruby-coderay)
+ ("ruby-method-source" ,ruby-method-source)
+ ("ruby-slop" ,ruby-slop-3)))
+ (synopsis "Ruby REPL")
+ (description "Pry is an IRB alternative and runtime developer console for
+Ruby. It features syntax highlighting, a plugin architecture, runtime
+invocation, and source and documentation browsing.")
+ (home-page "http://pryrepl.org")
+ (license license:expat)))