summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-03-31 10:33:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-03-31 10:36:31 +0200
commit967d5fd5c24883e0e33ca9b2f5b7d8a12805d57f (patch)
treec0ef85ea011f18e5d017395febd725bffdfb9d80
parentecb2603046dfc745a84314ba5921e082a3a68e22 (diff)
downloadguix-patches-967d5fd5c24883e0e33ca9b2f5b7d8a12805d57f.tar
guix-patches-967d5fd5c24883e0e33ca9b2f5b7d8a12805d57f.tar.gz
gnu: python2-h5py: Detach version and source from python-h5py.
* gnu/packages/python-xyz.scm (python2-h5py): Override source and version field. (python-h5py)[properties]: Record python2-variant.
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c576d2106a..a4d86ace92 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1388,10 +1388,21 @@ HDF5 library from Python. The low-level interface is intended to be a
complete wrapping of the HDF5 API, while the high-level component supports
access to HDF5 files, datasets and groups using established Python and NumPy
concepts.")
- (license license:bsd-3)))
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-h5py))))))
(define-public python2-h5py
- (package-with-python2 python-h5py))
+ (let ((base (package-with-python2 (strip-python2-variant python-h5py))))
+ (package
+ (inherit base)
+ (version "2.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "h5py" version))
+ (sha256
+ (base32
+ "0baipzv8n93m0dq0riyi8rfhzrjrfrfh8zqhszzp1j2xjac2fhc4")))))))
(define-public python-hnswlib
(package