summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-22 11:13:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-22 11:13:57 +0300
commit91c42e4767f36ba44b4a7170f5ae3aa3db2df76a (patch)
treed91615e55a14c382ea3394e85f4c7db08d2fd6fc
parent18f9e21b189ce4183ab8ec3e5ffce0559e47ce56 (diff)
downloadguix-patches-91c42e4767f36ba44b4a7170f5ae3aa3db2df76a.tar
guix-patches-91c42e4767f36ba44b4a7170f5ae3aa3db2df76a.tar.gz
gnu: abjad: Move lilypond to inputs.
* gnu/packages/music.scm (abjad)[native-inputs]: Move lilypond ... [inputs]: ... to here.
-rw-r--r--gnu/packages/music.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 395c0a5409..22133ce44c 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1592,8 +1592,7 @@ Guile.")
(invoke "python" "-m" "pytest" "tests")
#t))))))
(native-inputs
- `(("lilypond" ,lilypond)
- ("python-black" ,python-black)
+ `(("python-black" ,python-black)
("python-flake8" ,python-flake8)
("python-iniconfig" ,python-iniconfig)
("python-isort" ,python-isort)
@@ -1601,6 +1600,8 @@ Guile.")
("python-pytest" ,python-pytest-6)
("python-pytest-cov" ,python-pytest-cov)
("python-sphinx-autodoc-typehints" ,python-sphinx-autodoc-typehints)))
+ (inputs
+ `(("lilypond" ,lilypond)))
(propagated-inputs
`(("python-ply" ,python-ply)
("python-quicktions" ,python-quicktions)