summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-08 14:46:36 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-11-08 16:14:15 +0000
commit912dcbad86ddf1846c15b9ff3b2bb81fae32d894 (patch)
tree9943d0c0b405ba5ace792f1cfbb0bf2a6a8ebbac
parentfca4ff35594bbdff0a058fc4112b6ba523b7e1b0 (diff)
downloadguix-patches-912dcbad86ddf1846c15b9ff3b2bb81fae32d894.tar
guix-patches-912dcbad86ddf1846c15b9ff3b2bb81fae32d894.tar.gz
gnu: python-cryptography, python-cryptography-vectors: Update to 1.5.3.
* gnu/packages/python.scm (python-cryptography, python2-cryptography): Update to 1.5.3. [native-inputs]: Add python-pytz. Change python-pytest to python-pytest-2.9.2. (python-cryptography-vectors, python2-cryptography-vectors): Update to 1.5.3.
-rw-r--r--gnu/packages/python.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 01eadcd237..d5eae7d6fc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6552,14 +6552,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography-vectors
(package
(name "python-cryptography-vectors")
- (version "1.3.4")
+ (version "1.5.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography_vectors" version))
(sha256
(base32
- "15h1iz2klnpb4f8djxy7cpbnyn3wbjp7bnj4pz6s7w6plghbq524"))))
+ "1bnd1bricyhxa27rhr0ljk0kacxzvysd3ar2j2hlv13a2k6zw4z5"))))
(build-system python-build-system)
(native-inputs
`(("python-setuptools" ,python-setuptools)))
@@ -6576,14 +6576,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "1.3.4")
+ (version "1.5.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "1a85l548w5vvq3yhz0az7ajg2ijixzp6gagapw6wgrqvq28ghgs2"))))
+ "1raanvkdfw5ai56ymlij6ghc4k126fs7jx948ig7yn4vj6ndv0ng"))))
(build-system python-build-system)
(inputs
`(("openssl" ,openssl)))
@@ -6600,7 +6600,8 @@ responses, rather than doing any computation.")
("python-pretend" ,python-pretend)
("python-pyasn1" ,python-pyasn1)
("python-pyasn1-modules" ,python-pyasn1-modules)
- ("python-pytest" ,python-pytest)))
+ ("python-pytz" ,python-pytz)
+ ("python-pytest" ,python-pytest-2.9.2)))
(home-page "https://github.com/pyca/cryptography")
(synopsis "Cryptographic recipes and primitives for Python")
(description