summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:39 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:49 +0200
commit8e79e3dd3d325586684ec4c79d6d1400fa85966f (patch)
treed5db83c6ef409b011781c00cf150d15839886ebf
parent39e6cac94760b0f0a8c1c4877ff3ada9f2600ca9 (diff)
downloadguix-patches-8e79e3dd3d325586684ec4c79d6d1400fa85966f.tar
guix-patches-8e79e3dd3d325586684ec4c79d6d1400fa85966f.tar.gz
gnu: Add r-tidytext.
* gnu/packages/cran.scm (r-tidytext): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e7761158e2..f47bc63f72 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24021,3 +24021,36 @@ vignettes in all common formats.")
license:lgpl2.1
license:mpl1.1
license:expat))))
+
+(define-public r-tidytext
+ (package
+ (name "r-tidytext")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidytext" version))
+ (sha256
+ (base32
+ "0gck3f039qkpkwn92jlyfan76w0xydg17bh6nsg9qlba7c35kzs6"))))
+ (properties `((upstream-name . "tidytext")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dplyr" ,r-dplyr)
+ ("r-generics" ,r-generics)
+ ("r-hunspell" ,r-hunspell)
+ ("r-janeaustenr" ,r-janeaustenr)
+ ("r-matrix" ,r-matrix)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-stopwords" ,r-stopwords)
+ ("r-stringr" ,r-stringr)
+ ("r-tokenizers" ,r-tokenizers)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/juliasilge/tidytext")
+ (synopsis "Text mining using dplyr, ggplot2, and other Tidy tools")
+ (description
+ "This is a package for text mining for word processing and sentiment
+analysis using @code{dplyr}, @code{ggplot2}, and other Tidy tools.")
+ (license license:expat)))