summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-06-05 09:24:51 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-06-05 17:10:07 -0700
commit7f85e7ce4900a6c948458ecd6022db00bc6428e2 (patch)
tree144e9acc90f09931e7129e167ad64cce06f577c4
parent52cb6e6310b908d29948064d060b2abe0b576c0c (diff)
downloadguix-patches-7f85e7ce4900a6c948458ecd6022db00bc6428e2.tar
guix-patches-7f85e7ce4900a6c948458ecd6022db00bc6428e2.tar.gz
gnu: transmission: Do not embed kernel version in user agent.
* gnu/packages/bittorrent.scm (transmission)[arguments]: Add 'remove-kernel-version phase.
-rw-r--r--gnu/packages/bittorrent.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 1c9358b896..bc0364d87c 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -105,6 +105,11 @@
#:glib-or-gtk-wrap-excluded-outputs '("out")
#:phases
(modify-phases %standard-phases
+ ;; Avoid embedding kernel version for reproducible build
+ (add-after 'unpack 'remove-kernel-version
+ (lambda _
+ (substitute* "third-party/miniupnpc/updateminiupnpcstrings.sh"
+ (("OS_VERSION=`uname -r`") "OS_VERSION=Guix"))))
(add-after 'install 'move-gui
(lambda* (#:key outputs #:allow-other-keys)
;; Move the GUI to its own output, so that "out" doesn't