summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-22 20:43:56 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:36:10 +0200
commit51f3b34913442afbc638a6e3331a18df1a9e5d97 (patch)
treecf1119ed24a5a69536c520f80d874c359d5b534f
parent5a746104e3c91400099377fcc4bd763b9e91fb96 (diff)
downloadguix-patches-51f3b34913442afbc638a6e3331a18df1a9e5d97.tar
guix-patches-51f3b34913442afbc638a6e3331a18df1a9e5d97.tar.gz
gnu: vkquake: Fix build with newer Vulkan headers.
* gnu/packages/games.scm (vkquake)[arguments]: Add phase 'patch-for-new-vulkan'.
-rw-r--r--gnu/packages/games.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 111e1e0579..970cdbe613 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5807,6 +5807,14 @@ some graphical niceities, and numerous bug-fixes and other improvements.")
(string-append "LDFLAGS=-Wl,-rpath=" vulkanlib)
"-CQuake"))
#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-for-new-vulkan
+ (lambda _
+ ;; Mimic upstream commit a869a22d9b51c68e for
+ ;; compatibility with newer vulkan-headers.
+ (substitute* "Quake/gl_rmisc.c"
+ (("VK_DYNAMIC_STATE_RANGE_SIZE")
+ "3"))
+ #t))
(delete 'configure)
(add-after 'unpack 'fix-makefile-paths
(lambda* (#:key outputs #:allow-other-keys)