summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2013-01-15 02:49:01 +0000
committerLudovic Courtès <ludo@gnu.org>2013-01-19 22:20:47 +0100
commit3889a82ef889004bb0835c54e8dc8b23a4a6758f (patch)
treef6ead2ad7f1d4eff7ca4367cea304d7c6ee6b4d5
parent11314eb68e6207641f81c30bcd55ece0d9efa857 (diff)
downloadguix-patches-3889a82ef889004bb0835c54e8dc8b23a4a6758f.tar
guix-patches-3889a82ef889004bb0835c54e8dc8b23a4a6758f.tar.gz
distro: Add GLib.
* distro/packages/glib.scm: New file. * Makefile.am (MODULES): Add it.
-rw-r--r--Makefile.am3
-rw-r--r--gnu/packages/glib.scm59
2 files changed, 61 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4df699aa64..9ae0d3002b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,12 +66,13 @@ MODULES = \
gnu/packages/emacs.scm \
gnu/packages/file.scm \
gnu/packages/flex.scm \
- gnu/packages/freetype.scm \
+ gnu/packages/freetype.scm \
gnu/packages/gawk.scm \
gnu/packages/gdb.scm \
gnu/packages/gdbm.scm \
gnu/packages/gettext.scm \
gnu/packages/ghostscript.scm \
+ gnu/packages/glib.scm \
gnu/packages/global.scm \
gnu/packages/gnupg.scm \
gnu/packages/gnutls.scm \
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
new file mode 100644
index 0000000000..bbf64f2800
--- /dev/null
+++ b/gnu/packages/glib.scm
@@ -0,0 +1,59 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (distro packages glib)
+ #:use-module ((guix licenses) #:select (lgpl2.0+))
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (distro packages base)
+ #:use-module (distro packages compression)
+ #:use-module ((distro packages gettext)
+ #:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (distro packages libffi)
+ #:use-module (distro packages pkg-config)
+ #:use-module (distro packages python))
+
+(define-public glib
+ (package
+ (name "glib")
+ (version "2.34")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ftp.gnome.org/pub/gnome/sources/"
+ name "/" version "/"
+ name "-" version ".3" ".tar.xz"))
+ (sha256
+ (base32 "19sq4rhl2vr8ikjvl8qh51vr38yqfhbkb3imi2s6ac5rgkwcnpw5"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("coreutils" ,coreutils)
+ ("gettext" ,guix:gettext)
+ ("libffi" ,libffi)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)
+ ("zlib" ,zlib)))
+ (arguments `(#:tests? #f)) ; XXX: tests fail
+ (synopsis
+ "GLib, a library that provides the core application building blocks")
+ (description
+ "GLib provides data structure handling for C, portability wrappers,
+and interfaces for such runtime functionality as an event loop, threads,
+dynamic loading, and an object system.")
+ (home-page "http://developer.gnome.org/glib/")
+ (license lgpl2.0+))) ; some files are under lgpl2.1+ \ No newline at end of file