summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-06-01 09:24:00 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-06-04 15:25:02 -0700
commit32322d0926313d28276928d81188ee909e464eb0 (patch)
tree4b6af9a76ef31d278843c190ffbf3f5724824580
parent9f5236b829de0a64604d9f5581fdc4ee2e32d70b (diff)
downloadguix-patches-32322d0926313d28276928d81188ee909e464eb0.tar
guix-patches-32322d0926313d28276928d81188ee909e464eb0.tar.gz
gnu: keyutils: Avoid embedding build timestamp.
* gnu/packages/crypto.scm (keyutils)[arguments]: Add 'avoid-embedding-timestamp phase.
-rw-r--r--gnu/packages/crypto.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index e98d9634dc..6e4b1331e7 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -398,6 +398,11 @@ the wrong hands.")
#:phases
#~(modify-phases %standard-phases
(delete 'configure) ; no configure script
+ (add-after 'unpack 'avoid-embedding-timestamp
+ ;; Do not embed build timestamp
+ (lambda _
+ (substitute* "Makefile"
+ (("shell date") "shell true"))))
(add-after 'install 'install:static
(lambda _
(with-directory-excursion #$output