summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Lo <peterloleungyau@gmail.com>2020-06-29 13:50:42 +0800
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 18:29:49 +0200
commit23bd6f6ef135b205bc0f6f5c0d892366ea7fe98f (patch)
tree2c31fc8c87517dd6109e19d440e375e997e5d407
parent48d40c77178a0f69e2a7178b1e5d6ff6ac6ef095 (diff)
downloadguix-patches-23bd6f6ef135b205bc0f6f5c0d892366ea7fe98f.tar
guix-patches-23bd6f6ef135b205bc0f6f5c0d892366ea7fe98f.tar.gz
gnu: Add r-tidymodels.
* gnu/packages/cran.scm (r-tidymodels): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 089e3c527d..d420af1d2b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24119,3 +24119,49 @@ functions or computational engines (e.g. R, Spark, Stan, etc).")
"The objective of this package is to perform inference using an
expressive statistical grammar that coheres with the Tidy design framework.")
(license license:cc0)))
+
+(define-public r-tidymodels
+ (package
+ (name "r-tidymodels")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tidymodels" version))
+ (sha256
+ (base32
+ "1bi5vh80f6f2ibhyaapgnl7q1mkkx8425vj6ci0ml5rb7l8jhjm8"))))
+ (properties `((upstream-name . "tidymodels")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-broom" ,r-broom)
+ ("r-cli" ,r-cli)
+ ("r-crayon" ,r-crayon)
+ ("r-dials" ,r-dials)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-infer" ,r-infer)
+ ("r-magrittr" ,r-magrittr)
+ ("r-parsnip" ,r-parsnip)
+ ("r-pillar" ,r-pillar)
+ ("r-purrr" ,r-purrr)
+ ("r-recipes" ,r-recipes)
+ ("r-rlang" ,r-rlang)
+ ("r-rsample" ,r-rsample)
+ ("r-rstudioapi" ,r-rstudioapi)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyposterior" ,r-tidyposterior)
+ ("r-tidypredict" ,r-tidypredict)
+ ("r-tidytext" ,r-tidytext)
+ ("r-tune" ,r-tune)
+ ("r-workflows" ,r-workflows)
+ ("r-yardstick" ,r-yardstick)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/tidymodels/tidymodels")
+ (synopsis "Tidy collection for modeling and statistical analysis")
+ (description
+ "The tidy modeling \"verse\" is a collection of packages for modeling and
+statistical analysis that share the underlying design philosophy, grammar, and
+data structures of the tidyverse.")
+ (license license:gpl3)))