summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2021-10-19 02:13:58 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-14 15:14:51 +0100
commit1a72b6e999a8150dc3322412c570fa2c0ae49f2a (patch)
treee0c40d0b4c82f15c4a83dc060a92292df7549b1b
parentbd1f30047de5456e84fccbbc07b5b417fb90c92b (diff)
downloadguix-patches-1a72b6e999a8150dc3322412c570fa2c0ae49f2a.tar
guix-patches-1a72b6e999a8150dc3322412c570fa2c0ae49f2a.tar.gz
gnu: Add neatmail.
* gnu/packages/mail.scm (neatmail): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/mail.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f00e8ac7b3..aa9e6d3a3d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4488,6 +4488,41 @@ which can convert the contacts to @code{.ldif} format for import into LDAP
databases, and other tools to process Outlook email archives.")
(license license:gpl2+)))
+(define-public neatmail
+ (package
+ (name "neatmail")
+ (version "02")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/aligrudi/neatmail")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00d453d57d3v6ja2gpmjd8vch804c72g38pc1nr5shmz3hkgd52d"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:make-flags `((string-append "CC=" ,(cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ;no configure script
+ (replace 'install ;no install target in the Makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (rename-file "mail" "neatmail")
+ (install-file "neatmail" bin)))))))
+ (home-page "https://litcave.rudi.ir/")
+ (synopsis "Text-mode mail client")
+ (description
+ "@command{neatmail} is a noninteractive mail client. It generates
+a listing of the messages in a mailbox in mbox format and executes a list of
+ex-like commands on it.")
+ (license license:isc)))
+
(define-public crm114
(package
(name "crm114")