summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-22 00:44:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:20 -0500
commit000291fd4325d2afd1f9f93125986275f6e7ab7a (patch)
tree0c8abcd936773d025eed9995d4c14b5ee5572499
parentfeab09f72abc6d6eec16a1b8d27c231c747c0e00 (diff)
downloadguix-patches-000291fd4325d2afd1f9f93125986275f6e7ab7a.tar
guix-patches-000291fd4325d2afd1f9f93125986275f6e7ab7a.tar.gz
gnu: librsvg: Preserve the loaders.cache file.
Now that we have a search path that honors it on gdk-pixbuf, it is more valuable to keep it. * gnu/packages/gnome.scm (librsvg)[phases]{pre-configure}: Install loaders, cache file to locations derived from %gdk-pixbuf-loaders-cache-file.
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 1e1f989e4b..1e59dfa11b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3488,17 +3488,20 @@ for dealing with different structured file formats.")
(substitute* '("Makefile.am" "Makefile.in")
(("--locked") ""))))
(add-before 'configure 'pre-configure
- (lambda _
+ (lambda* (#:key outputs #:allow-other-keys)
(substitute* "gdk-pixbuf-loader/Makefile.in"
;; By default the gdk-pixbuf loader is installed under
;; gdk-pixbuf's prefix. Work around that.
(("gdk_pixbuf_moduledir = .*$")
(string-append "gdk_pixbuf_moduledir = "
- "$(prefix)/lib/gdk-pixbuf-2.0/2.10.0/"
- "loaders\n"))
- ;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
- (("gdk_pixbuf_cache_file = .*$")
- "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))))
+ "$(prefix)/"
+ ,(dirname %gdk-pixbuf-loaders-cache-file) "/"
+ "loaders\n")))
+ (substitute* "configure"
+ (("gdk_pixbuf_cache_file=.*")
+ (string-append "gdk_pixbuf_cache_file="
+ (assoc-ref outputs "out") "/"
+ ,%gdk-pixbuf-loaders-cache-file "\n")))))
(add-after 'configure 'gnu-configure
(lambda* (#:key outputs #:allow-other-keys #:rest args)
(apply (assoc-ref gnu:%standard-phases 'configure)