summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-24 23:45:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-25 00:03:00 -0400
commitbcf26fa54f4a9114a8363c179cdf9f58942b92f1 (patch)
tree35e9535b13b6e6b77c7179c71d673ddbbb572497
parent61e3b86cbf2238d13a557722e69cf3b343fa427d (diff)
downloadguix-patches-bcf26fa54f4a9114a8363c179cdf9f58942b92f1.tar
guix-patches-bcf26fa54f4a9114a8363c179cdf9f58942b92f1.tar.gz
gnu: Add python-pdbpp.
* gnu/packages/python-xyz.scm (python-pdbpp): New variable.
-rw-r--r--gnu/packages/python-xyz.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f9492908a3..bfe7031eba 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5587,6 +5587,51 @@ to the interactive prompt. It is an extension of the @code{rlcompleter}
module from the standard Python library.")
(license license:bsd-3)))
+(define-public python-pdbpp
+ (package
+ (name "python-pdbpp")
+ (version "0.10.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pdbpp" version))
+ (sha256
+ (base32
+ "1xb9yvi30rb1cdpvfdk2kg79vh3anvkz91r8bwvfp3iqv97kzr6r"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest"
+ "-k"
+ (string-append
+ ;; These tests seem to require a real TTY.
+ "not interaction_restores_previous_sigint_handler "
+ "and not python_m_pdb_uses_pdbpp"))))))))
+ (propagated-inputs
+ `(("python-fancycompleter" ,python-fancycompleter)
+ ("python-pygments" ,python-pygments)
+ ("python-wmctrl" ,python-wmctrl)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/pdbpp/pdbpp")
+ (synopsis "Drop-in replacement for pdb")
+ (description "Pdb++ is a drop-in replacement for @code{pdb}. It
+includes the following improvements compared to @code{pdb}:
+@itemize
+@item auto-completion
+@item syntax highlighting of code listings
+@item sticky mode
+@item new commands to be used from the interactive (Pdb++) prompt
+@item smart command parsing
+@item additional convenience functions in the @code{pdb} module.
+@end itemize")
+ (license license:bsd-3)))
+
(define-public python-pdftotext
(package
(name "python-pdftotext")