summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@disroot.org>2022-06-04 14:19:51 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:12 +0200
commitaa979449bca7fcd1401591636986c6ed3a572bd9 (patch)
treeb474f91ed0c7440418bb81094d12a717db9ccb16
parent3666e5e4097884fa161ed9d49293fccf36a1f7da (diff)
downloadguix-patches-aa979449bca7fcd1401591636986c6ed3a572bd9.tar
guix-patches-aa979449bca7fcd1401591636986c6ed3a572bd9.tar.gz
gnu: Add emacs-seq.
* gnu/packages/emacs-xyz (emacs-seq): New variable. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0707a7d4a5..41f9a76451 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31142,6 +31142,25 @@ wraps GNU Global calls and integration to editor using this API with
project.el and xref.el.")
(license license:gpl3+))))
+(define-public emacs-seq
+ (package
+ (name "emacs-seq")
+ (version "2.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/seq-" version ".tar"))
+ (sha256
+ (base32 "1lbxnrzq88z8k9dyylg2636pg9vc8bzfprs1hxwp9ah0zkvsn52p"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/seq.html")
+ (synopsis "Sequence manipulation functions")
+ (description
+ "This Emacs package provides sequence manipulation functions that
+complement basic functions provided by @file{subr.el}. All its functions
+are prefixed with @code{seq-} and work on lists, strings, and vectors.")
+ (license license:gpl3+)))
+
(define-public emacs-setup
(package
(name "emacs-setup")