summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-08-30 01:36:55 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-24 14:15:05 +0200
commit7020012817196d0918d17318a61737a22a738502 (patch)
tree8f1c2ef032e9847bba66faf0ad1082f894114f0d
parentb6cc5200c96dfefced5ab043191846a0bb23cee2 (diff)
downloadguix-patches-7020012817196d0918d17318a61737a22a738502.tar
guix-patches-7020012817196d0918d17318a61737a22a738502.tar.gz
gnu: Add python-box.
* gnu/packages/python-xyz.scm (python-box): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 299aa051a9..44ddb635a8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26845,3 +26845,26 @@ single-platform apps, there may by plenty of nuances in figuring out the right
location. This small Python module determines the appropriate
platform-specific directories, e.g. the ``user data dir''.")
(license license:expat)))
+
+(define-public python-box
+ (package
+ (name "python-box")
+ (version "5.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-box" version))
+ (sha256
+ (base32
+ "0jhrdif57khx2hsw1q6a9x42knwcvq8ijgqyq1jmll6y6ifyzm2f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-msgpack" ,python-msgpack)
+ ("python-ruamel.yaml" ,python-ruamel.yaml)
+ ("python-toml" ,python-toml)))
+ (home-page "https://github.com/cdgriffith/Box")
+ (synopsis "Advanced Python dictionaries with dot notation access")
+ (description
+ "This package provides the @code{python-box} Python module.
+It implements advanced Python dictionaries with dot notation access.")
+ (license license:expat)))