summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2021-08-30 01:38:13 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-24 14:18:38 +0200
commit4f92baeff9ca8047d4ff8e1c3d5f3152d44031a2 (patch)
tree333ec9bd9fd36aebf6be114819f585b35b15eb8b
parent7020012817196d0918d17318a61737a22a738502 (diff)
downloadguix-patches-4f92baeff9ca8047d4ff8e1c3d5f3152d44031a2.tar
guix-patches-4f92baeff9ca8047d4ff8e1c3d5f3152d44031a2.tar.gz
gnu: Add python-pep8-naming.
* gnu/packages/python-xyz.scm (python-pep8-naming): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44ddb635a8..257c1f9266 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9315,6 +9315,28 @@ PEP 8.")
(define-public python2-pep8
(package-with-python2 python-pep8))
+(define-public python-pep8-naming
+ (package
+ (name "python-pep8-naming")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pep8-naming" version))
+ (sha256
+ (base32
+ "04kyh9hkpyc8jzj16d1kkk29b5n8miqdvbs0zm035n1z5z5kx6hz"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-flake8-polyfill" ,python-flake8-polyfill)))
+ (home-page "https://github.com/PyCQA/pep8-naming")
+ (synopsis "Check PEP-8 naming conventions")
+ (description
+ "This package provides the @code{pep8-naming} Python module, a
+plugin for flake8 to check PEP-8 naming conventions.")
+ (license license:expat)))
+
(define-public python-pep517
(package
(inherit python-pep517-bootstrap)