summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-01 10:45:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-01 10:46:00 +0200
commit0c26c8da9d9bb86bfbe8fe9a52ba7b2ba9c6e3ec (patch)
treee45f6631b491ea60076e9ecde617279fc0c4fbe3
parent1600d5cd3a829f9472a64bbacad58887265f9e34 (diff)
downloadguix-patches-0c26c8da9d9bb86bfbe8fe9a52ba7b2ba9c6e3ec.tar
guix-patches-0c26c8da9d9bb86bfbe8fe9a52ba7b2ba9c6e3ec.tar.gz
gnu: pigx-rnaseq: Fix build.
* gnu/packages/bioinformatics.scm (pigx-rnaseq)[arguments]: Add phase 'patch-knitr.
-rw-r--r--gnu/packages/bioinformatics.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7059be7d24..6ce011af0f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10455,6 +10455,13 @@ once. This package provides tools to perform Drop-seq analyses.")
`(#:parallel-tests? #f ; not supported
#:phases
(modify-phases %standard-phases
+ ;; knitr 0.39 changes the default behavior of how graphics are
+ ;; included.
+ (add-after 'unpack 'patch-knitr
+ (lambda _
+ (substitute* "scripts/runDeseqReport.R"
+ (("outFile <- paste0" m)
+ (string-append "options(knitr.graphics.rel_path = FALSE)\n" m)))))
;; "test.sh" runs the whole pipeline, which takes a long time and
;; might fail due to OOM. The MultiQC is also resource intensive.
(add-after 'unpack 'disable-resource-intensive-test