summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-05-27 00:26:52 -0500
committerLudovic Courtès <ludo@gnu.org>2022-06-04 00:11:44 +0200
commitaf0b3fdbf98004e87dc4270b3a424fd09b70665b (patch)
tree9338d422c6f12d8d14ae4f9e185e236008a10992
parent7901639d244b203e673b0f59a28877d5710c9703 (diff)
downloadguix-patches-af0b3fdbf98004e87dc4270b3a424fd09b70665b.tar
guix-patches-af0b3fdbf98004e87dc4270b3a424fd09b70665b.tar.gz
gnu: python-shellingham: Update to 1.4.0.
* gnu/packages/python-xyz.scm (python-shellingham): Update to 1.4.0. [arguments]: Remove arguments block since upstream now includes a setup.py file. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f54bf340f5..979a11a5a6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16067,25 +16067,14 @@ implementation has been adapted, improved, and fixed from Molten.")
(define-public python-shellingham
(package
(name "python-shellingham")
- (version "1.3.2")
+ (version "1.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "shellingham" version))
(sha256
- (base32 "07kmia2hvd2q7wik89m82hig9mqr2faynvy38vxq5fm0ps11jv2p"))))
+ (base32 "07hpndvcv9mf9hp54b4apzpwzmzfzl8ryaacsfdq4139im2w4ma8"))))
(build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'restore-setup.py
- ;; setup.py will return in the next release.
- ;; <https://github.com/sarugaku/shellingham/issues/33>
- (lambda _
- (with-output-to-file "setup.py"
- (lambda _
- (display "from setuptools import setup\nsetup()\n")))
- #t)))))
(home-page "https://github.com/sarugaku/shellingham")
(synopsis "Tool to detect surrounding shell")
(description