summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominic Martinez <dom@dominicm.dev>2022-05-25 21:39:03 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-04 00:11:44 +0200
commit4b99360b8be6d7679fb6b3823c20c053fb02f45d (patch)
treed11ca8aa2a0b5122a5c3d5f45738e07b2e1820c1
parent7115a075f362dec5294584da7c3f3d62bfc81191 (diff)
downloadguix-patches-4b99360b8be6d7679fb6b3823c20c053fb02f45d.tar
guix-patches-4b99360b8be6d7679fb6b3823c20c053fb02f45d.tar.gz
gnu: emacs-benchmark-init: Update to 1.0-0243556.
* gnu/packages/emacs-xyz.scm (emacs-benchmark-init): Update to 1.0-0243556. Fixes build on emacs 28. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm36
1 files changed, 19 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ced6e1a482..0fd55c6931 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20230,24 +20230,26 @@ functions.")
(license license:gpl3+)))
(define-public emacs-benchmark-init
- (package
- (name "emacs-benchmark-init")
- (version "1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dholm/benchmark-init-el")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1kyn1izm5sbqbp9whnhk9dn3yc7zy8bz5san5w3ivi3rpx15fh94"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/dholm/benchmark-init-el")
- (synopsis "Benchmark Emacs @code{require} and @code{load} calls")
- (description "@code{benchmark-init} provides a way to keep track of where
+ (let ((commit "02435560415bbadbcf5051fb7042880549170e7e")
+ (revision "1"))
+ (package
+ (name "emacs-benchmark-init")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dholm/benchmark-init-el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19375vamhld4xm2qrdmhlp2nczfvalmz9x6ahl23zwkilr8n1nbw"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/dholm/benchmark-init-el")
+ (synopsis "Benchmark Emacs @code{require} and @code{load} calls")
+ (description "@code{benchmark-init} provides a way to keep track of where
time is being spent during Emacs startup in order to optimize startup time.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-magit-gerrit
(package