summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2022-05-16 17:47:21 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-01 23:28:19 +0200
commita5f20bebdcca920893e929a7da4ed7bd3406728f (patch)
tree12bc2f86b25cff46a1f2cf7fd3b353fee5a9afb3
parent03524641de059f355851d067082b0b1490e84730 (diff)
downloadguix-patches-a5f20bebdcca920893e929a7da4ed7bd3406728f.tar
guix-patches-a5f20bebdcca920893e929a7da4ed7bd3406728f.tar.gz
gnu: libstrophe: Improve package definition.
* gnu/packages/messaging.scm (libstrophe)[phases]: Use gexps. {install-extra-license-files}: New phase. [home-page]: Use https and add trailing /. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/messaging.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a3f7cc6047..8974e294cd 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2113,14 +2114,20 @@ manual SSL certificate verification.")
(base32 "1apply301lxyjax2677bd5mc0a3233nm5qb7fiqpawq2n7vh17v0"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags (list "--disable-static")
+ (list #:configure-flags '(list "--disable-static")
#:phases
- (modify-phases %standard-phases
+ #~(modify-phases %standard-phases
(add-after 'unpack 'patch-make
(lambda _
(substitute* "Makefile.am"
(("'\\^xmpp_'") "'.'"))
- #t)))))
+ #t))
+ (add-after 'install-licence-files 'install-extra-licence-files
+ (lambda _
+ (let ((license-directory (string-append #$output
+ "/share/doc/"
+ #$name "-" #$version "/")))
+ (install-file "MIT-LICENSE.txt" license-directory)))))))
(inputs
(list expat openssl))
(native-inputs
@@ -2129,7 +2136,7 @@ manual SSL certificate verification.")
(description "Libstrophe is a minimal XMPP library written in C. It has
almost no external dependencies, only an XML parsing library (expat or libxml
are both supported).")
- (home-page "http://strophe.im/libstrophe")
+ (home-page "https://strophe.im/libstrophe/")
;; Dual-licensed.
(license (list license:gpl3+ license:x11))))