summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-21 05:34:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:13 +0200
commit90091899949dee72afc80092995ef447e3bc588a (patch)
treef4ee9d5d4be60dd3c074d352865e151539d15878
parent00411836d9ece114a46f44ae1b8f7cb6d1a5ae35 (diff)
downloadguix-patches-90091899949dee72afc80092995ef447e3bc588a.tar
guix-patches-90091899949dee72afc80092995ef447e3bc588a.tar.gz
gnu: libmicrohttpd: Use G-expressions.
* gnu/packages/gnunet.scm (libmicrohttpd)[arguments]: Rewrite as G-expressions.
-rw-r--r--gnu/packages/gnunet.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 41e8f3b80f..76de8007a3 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Nikita <nikita@n0.is>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2020, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
@@ -69,6 +69,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xiph)
#:use-module (gnu packages backup)
+ #:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -171,6 +172,9 @@ tool to extract metadata from a file and print the results.")
"0bh39irwzkv48fkw43skfgkk8ka3793bx1lm21sgw6zxi0djyyx3"))
(patches (search-patches "libmicrohttpd-0.9.73-test-ssl3.patch"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "--disable-static")))
(inputs
(list curl gnutls/dane libgcrypt openssl zlib))
(synopsis "C library implementing an HTTP 1.1 server")