summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:01 +0200
commit81429d680da5c447d90bcd8d98596d149cf71789 (patch)
tree48adedf293eb9fd87be5cfd43a012d04e17982b2
parente1be3b947a9055728a1ae97d65d1663471ae94e6 (diff)
downloadguix-patches-81429d680da5c447d90bcd8d98596d149cf71789.tar
guix-patches-81429d680da5c447d90bcd8d98596d149cf71789.tar.gz
gnu: hwinfo: Rename non-standard ‘dev’ output.
* gnu/packages/hardware.scm (hwinfo)[outputs]: Rename ‘dev’ to ‘lib’. [arguments]: Ditto.
-rw-r--r--gnu/packages/hardware.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index 03a8df7174..b6d31d9485 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -141,7 +141,7 @@ sets, and tools to deal with register databases.")
(lambda (port)
(format port ,version)))))))
(build-system gnu-build-system)
- (outputs '("out" "dev" "doc"))
+ (outputs '("out" "lib" "doc"))
(arguments
`(#:tests? #f ; no test-suite available
#:phases
@@ -149,10 +149,10 @@ sets, and tools to deal with register databases.")
(add-after 'unpack 'patch
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (dev (assoc-ref outputs "dev"))
+ (lib (assoc-ref outputs "lib"))
(doc (assoc-ref outputs "doc"))
- (incl-dir (string-append dev "/include"))
- (lib-dir (string-append dev "/lib"))
+ (incl-dir (string-append lib "/include"))
+ (lib-dir (string-append lib "/lib"))
(sbin-dir (string-append out "/sbin"))
(share-dir (string-append out "/share"))
(doc-dir (string-append doc "/share/doc")))
@@ -172,16 +172,16 @@ sets, and tools to deal with register databases.")
(("/usr/sbin") sbin-dir)
(("/usr/share") share-dir)
(("\\$\\(DESTDIR\\)/sbin ") ""))
- ;; Add output "dev" to the run-path.
+ ;; Add the "lib" output to the run-path.
(substitute* "Makefile.common"
(("-Lsrc")
(string-append "-Lsrc " "-Wl,-rpath=" lib-dir)))
;; Correct program name of the lexical analyzer.
(substitute* "src/isdn/cdb/Makefile"
(("lex isdn_cdb.lex") "flex isdn_cdb.lex"))
- ;; Patch pkgconfig file to point to output "dev".
+ ;; Patch pkg-config file to point to the "lib" output.
(substitute* "hwinfo.pc.in"
- (("/usr") dev)))))
+ (("/usr") lib)))))
(delete 'configure)
(replace 'build
(lambda _