summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-06-01 12:18:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-06-01 12:19:48 +0200
commit6e54ce9ca9b172189ab46eb14147304ff9cfa35b (patch)
tree145959f536f8e17975f4ef6f7d128da87cf01efe
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
downloadguix-patches-6e54ce9ca9b172189ab46eb14147304ff9cfa35b.tar
guix-patches-6e54ce9ca9b172189ab46eb14147304ff9cfa35b.tar.gz
gnu: pigx-chipseq: Update to 0.1.0.
* gnu/packages/bioinformatics.scm (pigx-chipseq): Update to 0.1.0. [source]: Remove patch. [arguments]: Remove 'autoreconf phase. [native-inputs]: Remove autoconf and automake. * gnu/packages/patches/pigx-chipseq-no-citeproc.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove patch.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm19
-rw-r--r--gnu/packages/patches/pigx-chipseq-no-citeproc.patch33
3 files changed, 3 insertions, 50 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index af92253ddd..b9d62a3f0f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1629,7 +1629,6 @@ dist_patch_DATA = \
%D%/packages/patches/picprog-non-intel-support.patch \
%D%/packages/patches/pidgin-add-search-path.patch \
%D%/packages/patches/pigx-bsseq-no-citeproc.patch \
- %D%/packages/patches/pigx-chipseq-no-citeproc.patch \
%D%/packages/patches/pinball-system-ltdl.patch \
%D%/packages/patches/pingus-boost-headers.patch \
%D%/packages/patches/pingus-sdl-libs-config.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1ffac1a0ca..f2800d3163 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10526,7 +10526,7 @@ expression report comparing samples in an easily configurable manner.")
(define-public pigx-chipseq
(package
(name "pigx-chipseq")
- (version "0.0.53")
+ (version "0.1.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/BIMSBbioinfo/pigx_chipseq/"
@@ -10534,25 +10534,12 @@ expression report comparing samples in an easily configurable manner.")
"/pigx_chipseq-" version ".tar.gz"))
(sha256
(base32
- "0c6npx35sszycf059w1x1k4k9hq1qqxny0i4p57q1188czr4561h"))
- (patches (search-patches "pigx-chipseq-no-citeproc.patch"))))
+ "008n6drj9q5av86xihxlj4py2c9p3c5z5ld89c3bksrp77zxiy67"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; parts of the tests rely on access to the network
#:phases
(modify-phases %standard-phases
- (add-before 'bootstrap 'autoreconf
- (lambda _
- ;; This was fixed in commit
- ;; 0b1c9f7f2e4d0ff601f1de95ab8b2953f4d5dbc7, but there is no
- ;; release with this fix.
- (call-with-output-file "VERSION"
- (lambda (port) (display ,version port)))
- ;; See https://github.com/BIMSBbioinfo/pigx_chipseq/issues/176
- (substitute* "m4/ax_r_package.m4"
- (("if\\(is.na\\(packageDescription\\(\"PKG\"\\)\\)\\)")
- "if(system.file(package=\"PKG\") == \"\")"))
- (invoke "autoreconf" "-vif")))
(add-before 'configure 'set-PYTHONPATH
(lambda _
(setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH")))))))
@@ -10606,7 +10593,7 @@ expression report comparing samples in an easily configurable manner.")
bedtools
kentutils))
(native-inputs
- (list autoconf automake python-pytest))
+ (list python-pytest))
(home-page "https://bioinformatics.mdc-berlin.de/pigx/")
(synopsis "Analysis pipeline for ChIP sequencing experiments")
(description "PiGX ChIPseq is an analysis pipeline for preprocessing, peak
diff --git a/gnu/packages/patches/pigx-chipseq-no-citeproc.patch b/gnu/packages/patches/pigx-chipseq-no-citeproc.patch
deleted file mode 100644
index b01820f110..0000000000
--- a/gnu/packages/patches/pigx-chipseq-no-citeproc.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur pigx_chipseq-0.0.53/configure.ac pigx_chipseq-0.0.53.patched/configure.ac
---- pigx_chipseq-0.0.53/configure.ac 2021-09-28 11:14:12.000000000 +0200
-+++ pigx_chipseq-0.0.53.patched/configure.ac 2021-10-07 14:48:53.034054327 +0200
-@@ -52,7 +52,6 @@
- find_or_override_prog([MACS2], [macs2])
- find_or_override_prog([SNAKEMAKE], [snakemake])
- find_or_override_prog([PANDOC], [pandoc])
--find_or_override_prog([PANDOC_CITEPROC], [pandoc-citeproc])
- find_or_override_prog([FASTQC], [fastqc])
- find_or_override_prog([BOWTIE2], [bowtie2])
- find_or_override_prog([BOWTIE2_BUILD], [bowtie2-build])
-diff -Naur pigx_chipseq-0.0.53/Makefile.in pigx_chipseq-0.0.53.patched/Makefile.in
---- pigx_chipseq-0.0.53/Makefile.in 2021-09-28 11:55:05.000000000 +0200
-+++ pigx_chipseq-0.0.53.patched/Makefile.in 2021-10-07 14:48:37.195577143 +0200
-@@ -407,7 +407,6 @@
- PACKAGE_URL = @PACKAGE_URL@
- PACKAGE_VERSION = @PACKAGE_VERSION@
- PANDOC = @PANDOC@
--PANDOC_CITEPROC = @PANDOC_CITEPROC@
- PATH_SEPARATOR = @PATH_SEPARATOR@
- PERL = @PERL@
- PYTHON = @PYTHON@
-diff -Naur pigx_chipseq-0.0.53/pigx-common/common/pigx-runner.in pigx_chipseq-0.0.53.patched/pigx-common/common/pigx-runner.in
---- pigx_chipseq-0.0.53/pigx-common/common/pigx-runner.in 2021-09-27 18:16:42.000000000 +0200
-+++ pigx_chipseq-0.0.53.patched/pigx-common/common/pigx-runner.in 2021-10-07 14:48:44.200788218 +0200
-@@ -379,7 +379,6 @@
- if path.exists(bin): shutil.rmtree(bin)
- os.makedirs(bin, exist_ok=True)
- os.symlink('@PANDOC@', path.join(bin, "pandoc"))
-- os.symlink('@PANDOC_CITEPROC@', path.join(bin, "pandoc-citeproc"))
- os.symlink('@RSCRIPT@', path.join(bin, "Rscript"))
- os.environ['PATH'] = path.abspath(bin) + ":" + os.environ['PATH']
- os.environ['PIGX_PATH'] = path.abspath(bin) + ":" + os.environ['PATH']