summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-06-02 11:44:28 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-06-02 11:50:19 -0700
commit615239d5caa5f668894bfccbb35f5ffa6b756615 (patch)
treec22e465c8c5cc7ff178139154c9f96101a59e1a7
parentbf9da5ccc908376c84d0dfc7f1531fb479d23134 (diff)
downloadguix-patches-615239d5caa5f668894bfccbb35f5ffa6b756615.tar
guix-patches-615239d5caa5f668894bfccbb35f5ffa6b756615.tar.gz
gnu: gnustandards: Build reproducibly.
Avoid embedding timestamp in info.gz files. * gnu/packages/gnu-doc.scm (gnustandards)[arguments]: Pass "-n" to gzip invocations.
-rw-r--r--gnu/packages/gnu-doc.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/gnu-doc.scm b/gnu/packages/gnu-doc.scm
index 9fb746ee97..22fc976425 100644
--- a/gnu/packages/gnu-doc.scm
+++ b/gnu/packages/gnu-doc.scm
@@ -89,8 +89,8 @@ list.")
(string-append source "/maintain.texi"))
(invoke "makeinfo" "--output" info-dir
(string-append source "/standards.texi"))
- (invoke "gzip" (string-append info-dir "/maintain.info"))
- (invoke "gzip" (string-append info-dir "/standards.info"))))))
+ (invoke "gzip" "-n" (string-append info-dir "/maintain.info"))
+ (invoke "gzip" "-n" (string-append info-dir "/standards.info"))))))
(home-page "https://www.gnu.org/prep/standards/")
(synopsis "GNU coding standards and maintainer information")
(description "The GNU Coding Standards were written by Richard Stallman