summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2022-05-15 19:41:33 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-01 22:43:52 +0200
commit47792b9b56452d9cb64a36cd0b6effc65c6b2b67 (patch)
tree8b8a623c4e6c1a86f6866104bec288e8e4100bce
parent2acc83daa5a3dd1b4ed3f8c32ecadf1313e6fd18 (diff)
downloadguix-patches-47792b9b56452d9cb64a36cd0b6effc65c6b2b67.tar
guix-patches-47792b9b56452d9cb64a36cd0b6effc65c6b2b67.tar.gz
gnu: Add emacs-bfuture.
* gnu/packages/emacs-xyz.scm (emacs-bfuture): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 22d723c879..178b8ab90a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24824,6 +24824,34 @@ debug server. It is similar to the LSP but provides integration with
Debug server.")
(license license:gpl3+)))
+(define-public emacs-bfuture
+ (package
+ (name "emacs-bfuture")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~plattfot/bfuture")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1m4v4xbsvg26z7nvg2c8q7x1nvv7v4ajm56l0nbkwcbdbrgahpva"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:tests? (not (%current-target-system))
+ #:test-command #~'("ert-runner")))
+ (native-inputs (list emacs-ert-runner))
+ (home-page "https://github.com/plattfot/bfuture.el")
+ (synopsis "Basic future concept for Emacs with Tramp support")
+ (description
+ "This package provides basic functions for spawning processes asynchronous in
+Emacs and retrieving the output. It is similar to @code{emacs-pfuture} except
+that this works over Tramp but the feature set is more limited. For example,
+it cannot tell stdout and stderr apart.")
+ (license license:gpl3+)))
+
(define-public emacs-pfuture
(package
(name "emacs-pfuture")