summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Arroyo <david@aqwari.net>2022-05-29 16:42:34 -0400
committerJulien Lepiller <julien@lepiller.eu>2022-06-02 07:43:01 +0200
commit21800bf8b98871c99c0a91d97690be1df07a2659 (patch)
tree86cad76e7b1d9647e2111595d1d49ce9b71043e0
parentb96003cd69909f77cd4cb643b6951baa2e71d5f1 (diff)
downloadguix-patches-21800bf8b98871c99c0a91d97690be1df07a2659.tar
guix-patches-21800bf8b98871c99c0a91d97690be1df07a2659.tar.gz
gnu: ocaml-ctypes: do not override install headers
Overriding INSTALL_HEADERS in the build prevents the "ocaml_integers.h" header from being copied from the ocaml-integers package to ocaml-ctypes. The header's absence breaks all dune-based projects which build cstubs using the new (ctypes ...) stanza. * gnu/packages/ocaml.scm (ocaml-ctypes)[arguments]: remove INSTALL_HEADERS override. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/ocaml.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 79610e84bf..ec5757e87d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4333,9 +4333,7 @@ long and size_t whose sizes depend on the host platform.")
"0ilzq9qzvwv9rc08cc9wchsx636zp870i7qvqmbigaa2qb812m0z"))))
(build-system ocaml-build-system)
(arguments
- `(#:make-flags
- (list (string-append "INSTALL_HEADERS = $(wildcard $($(PROJECT).dir)/*.h)"))
- #:phases
+ `(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-writable
(lambda _