summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-06-01 19:17:50 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-06-01 19:33:37 -0700
commit1d7222590361ecb0ff56b42872ca6e5754732d08 (patch)
tree7897a6be8403088e8b118b064c879b1a4a6bec82
parent32f001ce48eb0a0fa0f517fec605f2b7d37601f8 (diff)
downloadguix-patches-1d7222590361ecb0ff56b42872ca6e5754732d08.tar
guix-patches-1d7222590361ecb0ff56b42872ca6e5754732d08.tar.gz
gnu: diffoscope: Fix embedded tool references.
Upstream switched from using '' to "" in various places. Drop patching of "readelf" which broke tests. * gnu/packages/diffoscope.scm (diffoscope)[arguments]: Update 'fix-embed-tool-references phase. [inputs]: Add coreutils and diffutils.
-rw-r--r--gnu/packages/diffoscope.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 16e3b2a481..de0ace0107 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -98,19 +98,19 @@
(add-after 'unpack 'embed-tool-references
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "diffoscope/comparators/utils/compare.py"
- (("\\['xxd',")
- (string-append "['" (which "xxd") "',")))
- (substitute* "diffoscope/comparators/elf.py"
- (("@tool_required\\('readelf'\\)") "")
- (("get_tool_name\\('readelf'\\)")
- (string-append "'" (which "readelf") "'")))
+ (("\\[\"xxd\",")
+ (string-append "[\"" (which "xxd") "\",")))
+ (substitute* "diffoscope/diff.py"
+ (("@tool_required\\(\"diff\"\\)") "")
+ (("get_tool_name\\(\"diff\"\\)")
+ (string-append "get_tool_name(\"" (which "diff") "\")")))
(substitute* "diffoscope/comparators/directory.py"
- (("@tool_required\\('stat'\\)") "")
- (("@tool_required\\('getfacl'\\)") "")
- (("\\['stat',")
- (string-append "['" (which "stat") "',"))
- (("\\['getfacl',")
- (string-append "['" (which "getfacl") "',")))))
+ (("@tool_required\\(\"stat\"\\)") "")
+ (("@tool_required\\(\"getfacl\"\\)") "")
+ (("\\[\"stat\",")
+ (string-append "[\"" (which "stat") "\","))
+ (("\\[\"getfacl\",")
+ (string-append "[\"" (which "getfacl") "\",")))))
(add-after 'build 'build-man-page
(lambda* (#:key (make-flags '()) #:allow-other-keys)
(apply invoke "make" "-C" "doc" make-flags)))
@@ -147,7 +147,8 @@
python-magic
python-tlsh
acl ;for getfacl
- colordiff
+ coreutils ;for stat
+ diffutils ;for diff
xxd))
(native-inputs
(append