summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:12 +0200
commit3d69f2dae8c5d451e03d3569c8b153fd573054b8 (patch)
tree025e55708a062a6ef205ad87582f4ab822684517
parentf33fd4372afe6db4cc603eaa049ed0c9a00d0994 (diff)
downloadguix-patches-3d69f2dae8c5d451e03d3569c8b153fd573054b8.tar
guix-patches-3d69f2dae8c5d451e03d3569c8b153fd573054b8.tar.gz
* gnu/packages/serialization.scm (libcyaml)[arguments]: Use #:test-target rather than a custom 'check phase. Use CC-FOR-TARGET.
-rw-r--r--gnu/packages/serialization.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 8b5b06484a..cec9b68299 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -367,16 +367,13 @@ that implements both the msgpack and msgpack-rpc specifications.")
(base32 "0gvf3h8r8300wdwfjgxw3nzlj7w14q63m67p8wdm5fvpha017n4y"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
+ `(#:test-target "test"
+ #:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "CC=gcc"))
+ (string-append "CC=" ,(cc-for-target)))
#:phases
(modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (replace 'check
- (lambda _
- (setenv "CC" "gcc")
- (invoke "make" "test"))))))
+ (delete 'configure)))) ; no configure script
(inputs
(list libyaml))
(native-inputs