summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 21:49:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:06 -0400
commitec822034d9fb0cb97be04342bed399489bef1b0a (patch)
treef18b47b4f094bfd9440c0004eaa4202e436627c2
parent098372a81e61f92bab4439c9bbaf43a73e1649b3 (diff)
downloadguix-patches-ec822034d9fb0cb97be04342bed399489bef1b0a.tar
guix-patches-ec822034d9fb0cb97be04342bed399489bef1b0a.tar.gz
gnu: john-the-ripper-jumbo: Use Python 3.
* gnu/packages/password-utils.scm (john-the-ripper-jumbot): [inputs]: Use new style and replace python-2 by python-wrapper. [phases]{install}: Delete trailing #t.
-rw-r--r--gnu/packages/password-utils.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 348afb5af4..127cfdf7aa 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2021 David Dashyan <mail@davie.li>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -951,13 +952,13 @@ between hosts and entries in the password store.")
(native-inputs
(list perl))
(inputs
- `(("gmp" ,gmp)
- ("libpcap" ,libpcap)
- ("nss" ,nss)
- ("openssl" ,openssl)
- ("python" ,python-2) ; For "python" and "python2" shebangs
- ("ruby" ,ruby) ; For genincstats.rb
- ("zlib" ,zlib)))
+ (list gmp
+ libpcap
+ nss
+ openssl
+ python-wrapper
+ ruby ; For genincstats.rb
+ zlib))
(arguments
`(#:configure-flags
(list "--with-systemwide"
@@ -1018,8 +1019,7 @@ between hosts and entries in the password store.")
(find-files "." "(.*\\.chr|.*\\.lst)")
(find-files "." ".*\\.conf")))
(copy-recursively "rules" (string-append datadir "/rules")))
- (copy-recursively "../doc" docdir)
- #t)))
+ (copy-recursively "../doc" docdir))))
(delete 'check) ; Tests need installed .conf files; move after install
(add-after 'install 'check
(lambda args