summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-10 01:05:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:01 -0400
commitdad15bdb26edbdf7b80519a2e7d0edf4e1efcd5f (patch)
treea8439937aea8c6d6956cb16f8ee6f0d59ba014e8
parentf880fc7b88f25f9cca59dffabd9de6dd0ab24fc9 (diff)
downloadguix-patches-dad15bdb26edbdf7b80519a2e7d0edf4e1efcd5f.tar
guix-patches-dad15bdb26edbdf7b80519a2e7d0edf4e1efcd5f.tar.gz
gnu: Add python-launchpadlib.
* gnu/packages/python-web.scm (python-launchpadlib): New variable.
-rw-r--r--gnu/packages/python-web.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 47ba88882f..bfbae3ce07 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -134,6 +134,35 @@
adds functionality on top of @code{wadlib}.")
(license license:lgpl3+)))
+(define-public python-launchpadlib
+ (package
+ (name "python-launchpadlib")
+ (version "1.10.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "launchpadlib" version))
+ (sha256
+ (base32 "106aixwchwyb100wlf4cnj1vgsi2d7x40ps8xv8az27r6qwv3x0d"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ (lambda _
+ ;; Tests require a writable home.
+ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs
+ (list python-httplib2
+ python-keyring
+ python-lazr-restfulclient
+ python-lazr-uri))
+ (native-inputs (list python-mock python-testresources python-wadllib))
+ (home-page "https://help.launchpad.net/API/launchpadlib")
+ (synopsis "Python client library for Launchpad's web service")
+ (description "@code{launchpadlib} is a Python library that allows
+scripting Launchpad via its the web service API.")
+ (license license:lgpl3+)))
+
(define-public python-lazr-uri
(package
(name "python-lazr-uri")