summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:19:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:17 -0400
commitad030a0b7dc0225dae03686a51a9b7b0236cad34 (patch)
tree9f5717c5e44b87b0d7001b5eb6c31a69ca96b803
parentd397cb6207ab96d476d4ea8880a675b67f429bf5 (diff)
downloadguix-patches-ad030a0b7dc0225dae03686a51a9b7b0236cad34.tar
guix-patches-ad030a0b7dc0225dae03686a51a9b7b0236cad34.tar.gz
gnu: Remove pplacer-scripts.
* gnu/packages/bioinformatics.scm (pplacer-scripts): Delete variable.
-rw-r--r--gnu/packages/bioinformatics.scm39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 64e4171f8f..d004124ddb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13245,45 +13245,6 @@ Additionally, the AdapterRemoval may be used to recover a consensus adapter
sequence for paired-ended data, for which this information is not available.")
(license license:gpl3+)))
-;; This package is installed alongside 'pplacer'. It is a separate package so
-;; that it can use the python-build-system for the scripts that are
-;; distributed alongside the main OCaml binaries.
-(define pplacer-scripts
- (package
- (inherit pplacer)
- (name "pplacer-scripts")
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'enter-scripts-dir
- (lambda _ (chdir "scripts") #t))
- (replace 'check
- (lambda _ (invoke "python" "-m" "unittest" "discover" "-v") #t))
- (add-after 'install 'wrap-executables
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (let ((path (string-append
- (assoc-ref inputs "hmmer") "/bin:"
- (assoc-ref inputs "infernal") "/bin")))
- (display path)
- (wrap-program (string-append bin "/refpkg_align.py")
- `("PATH" ":" prefix (,path))))
- (let ((path (string-append
- (assoc-ref inputs "hmmer") "/bin")))
- (wrap-program (string-append bin "/hrefpkg_query.py")
- `("PATH" ":" prefix (,path)))))
- #t)))))
- (inputs
- `(("infernal" ,infernal)
- ("hmmer" ,hmmer)))
- (propagated-inputs
- `(("python-biopython" ,python2-biopython)
- ("taxtastic" ,taxtastic)))
- (synopsis "Pplacer Python scripts")))
-
(define-public checkm
(package
(name "checkm")